Linux

VirtualBox + CentOS Hangs on “NET: Registered protocol family 2”

July 31, 2012

I was given a guest VM of CentOS to work with and when I tried to fire it up it would always hang on “NET: Registered protocol family 2” on each of my computers. I figured there must be some setting to turn on/off and after playing around with I discovered it was the following setting:

Just Enable IO APIC and start the VM again and it should boot with no issues!

Only registered users can comment.

  1. It’s really awesome when you google a problem you’re having and find a result with the exact same problem and a simple, clear solution. Thanks!

  2. Dude, thanks for sharing the tip. Centos 6 is available since last year, but I still need to do tests for old Centos 5.x servers.

    Regards, MV.

  3. Thanks, I was having a similar problem with the Elastix VOIP software. This was really helpful!

  4. I am trying to install Oracle enterprise Linux on Oracle virtual box. It is getting hung up the error Net : Registered protocol family 2

    After changing the above settings it still hung up .. ๐Ÿ™

    Please advice here ….

  5. @Santosh – Sorry but I am not Virtual Box technical support. If what I wrote doesn’t help you then you’ll have to keep searching for the answers.

  6. How do you enable the system setting?For me it is showing like a watermark.i am not able to click anything.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.